Trust ID PBCEX logo 300x102

Provider not compatible with Oracle client version

9 years 2 months ago
Rutger Koperdraad
Platinum Boarder
Platinum Boarder
Posts: 1566
More
Topic Author
Provider not compatible with Oracle client version #2242
"When connecting to Oracle, I get the following error message:

Could not connect to [New database].
The type initializer for 'Oracle.DataAccess.Client.OracleConnection' threw an exception.
The provider is not compatible with the version of Oracle client.


What should I do?"

Rutger Koperdraad
Senior Software Engineer

"A reasonable man adapts himself to the world. The unreasonable man persists in trying to adapt the world to himself. All progress, therefore, depends on the unreasonable man." (Bernard Shaw)
9 years 2 months ago
Rutger Koperdraad
Platinum Boarder
Platinum Boarder
Posts: 1566
More
Topic Author
Provider not compatible with Oracle client version #2243
Dear CardExchange user,

To connect to an Oracle database, you need to install the Oracle Data Provider for .NET 2.0 version 11.2.0.2.0, which can be downloaded from

http://www.oracle.com/technetwork/topics/dotnet/index-085163.html

Please, note that the data provider is combined with several other products in a single installer. During installation, you only need to select the Oracle Data Provider for .NET 2.0. Also note that you need to install this version of the Oracle Data Provider for .NET, even if you are connecting to an older version of the Oracle database. If you need to connect to newer version of the Oracle database, please, connect our Sales department or respond to this post.

regards,
Rutger.

Rutger Koperdraad
Senior Software Engineer

"A reasonable man adapts himself to the world. The unreasonable man persists in trying to adapt the world to himself. All progress, therefore, depends on the unreasonable man." (Bernard Shaw)